Aby w pełni korzystać z serwisu należy się zarejestrować. Można to zrobić TUTAJ
Zapraszamy także na Forum
Ten aplet jest widoczny tylko dla niezarejestrowanych użytkowników!
Strona Główna · Poradniki · Download · Forum · Linki · FAQ Sierpień 21 2017 14:03:29
Zobacz Temat
cod2mod - Jedyny polski portal wyłącznie nt. tworzenia map i modów do Call of Duty 2 | Pomoc | Wszystko
Autor problem
~inspektor
Użytkownik

Dodane dnia 27-04-2011 17:04
elo,
podczas tworzenia prostej, testowej mapki wszystko robilem zgodnie z poradnikiem umieszczonym na tej stronce. Po skompilowaniu mapy i uruchomieniu wszystkie tekstury nieba sie wczytaly ale tekstura ziemi po której chodze jest czarna. Zawsze jest czarna niezaleznie od tekstury która wybiore. Wiecie w czym problem? smiley
Z góry dziekuje.

@edit :
korzystając z okazji, jak stworzyć ściane (sama teksture) przez która moge przechodzic?
Edytowane przez inspektor dnia 27-04-2011 19:27
Wyślij Prywatną Wiadomość
Autor RE: problem
^Tomalla
Administrator

Dodane dnia 27-04-2011 22:03
Problem na bank leży w oświetleniu. Skoro masz otwartą przestrzeń, musisz ustawić jakiekolwiek ustawienia worldspawn mapy. To jedyne "pełne" wyjście. Drugie to dodanie parę obiektów 'light' na mapę, ale w praktyce dobrze się to sprawdza jedynie w zamkniętych pomieszczeniach.

Co do drugiego pytania, sprecyzuj. Chodzi ci np. o ścianę w budynku, przez którą można "magicznie" przejść, nie wiem, do ukrytego schowka czy coś w tym guście? Czy może o coś innego?


=-.-=-.-=-.-=-.-=-.-=
Stary wyjadacz CoD2
Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 28-04-2011 15:04
chodzi mi o ściane w budynku przez którą moge przejść

no i jeszcze trzecie pytanko:
tym razem zrobilem mape pod multi po skompilowaniu mapy chce ją włączyć ale za kazdym razem pojawia sie blad:
******* script compile error *******
Could not find script 'maps/mp/your_map_name_fx': (file 'maps/mp/mp_prototype.gsc', line 3)
maps\mp\your_map_name_fx::main();
*
************************************
writing to: C:\Program Files\Activision\Call of Duty 2\servercache.dat
Error during initialization:
script compile error
(see console for details)



czy do testowania mapy multi trzeba miec wlasny serwer?
Edytowane przez inspektor dnia 28-04-2011 16:23
Wyślij Prywatną Wiadomość
Autor RE: problem
^Tomalla
Administrator

Dodane dnia 28-04-2011 16:53
Zaznacz brusha, który jest twoją ścianą, klikasz prawym przyciskiem na viewport i menu które się pojawi wybierz opcję: Make Non-Colliding. Po skompilowaniu mapy gracze będą mogli spokojnie przez tą ścianę przechodzić.

Co do twojego błędu ... otwórz sobie plik mp_prototype.gsc. W trzeciej linijce z tego co się orientuję masz:

maps\mp\your_map_name_fx::main();




Zamień to na:

\\maps\mp\your_map_name_fx::main();




... czyli po prostu dodaj \\ na początku linijki. Albo ją w ogóle skasuj, efekt będzie ten sam smiley

Do testowania mapy trzeba postawić serwer ... nawet jeżeli chodzi o mapkę SP smiley Chodzi mi o to, że nie musisz stawiać serwera jako takiego. Wystarczy że w konsoli dasz:

sv_pure 0
devmap mp_prototype


... i już masz automatycznie stworzony serwer lokalny smiley Pozdro


=-.-=-.-=-.-=-.-=-.-=
Stary wyjadacz CoD2
Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 28-04-2011 17:01
dobra, zrobiłem tak jak kazałeś i pojawia mi sie kolejny błąd :
************************************
writing to: C:\Program Files\Activision\Call of Duty 2\servercache.dat
Error during initialization:
script runtime error
(see console for details)
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 10)



swojego serweru lokalnego też nie moge utworzyć ponieważ pojawia sie błąd:
Attempted to overrun string in call to va()


Wyślij Prywatną Wiadomość
Autor RE: problem
^Tomalla
Administrator

Dodane dnia 28-04-2011 19:19
Coś masz ze skryptami źle. Mam wrażenie, że ten 'błąd', który mi pokazałeś, jest nie kompletny. Podaj cały fragment z loga, który opisuje błąd.

Co do drugiego błędu, podejrzewam że jest to wina modów które możesz mieć w folderze "main". Spróbuj skasować ( albo przenieść gdzieś indziej ) wszystkie mody i spróbuj ponownie.


=-.-=-.-=-.-=-.-=-.-=
Stary wyjadacz CoD2
Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 28-04-2011 22:27
wielkie dzięki, wszystko działa ;p



@ wiecie jak stworzyć drzwi tak aby po nacisnieciu F otwieraly sie? (sry ze nie edytuje ale nie moge ;p)

@V czyli do dzisiaj, jasne jasne smiley
Edytowane przez inspektor dnia 29-04-2011 13:41
Wyślij Prywatną Wiadomość
Autor RE: problem
@explo32wunderwaffe
Super Administrator

Dodane dnia 01-05-2011 13:32
Nie zdążyłem na wtedy z tym poradnikiem, ale zdołałem go dokończyć wczoraj smiley Mam nadzieję, że uda ci się na jego podstawie zrobić drzwi.



Edytowane przez explo32wunderwaffe dnia 01-05-2011 13:33
3212459 explo32wunderwaffe lukaszu www.usmc-clan.tk Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 02-05-2011 18:13
wielkie dzięki za wszystko smiley
teraz co prawda znowu wszystkie tekstury są czarne (tak jakby nie oświetlone) ale z tym juz sam sobie jakos poradze.
jeszcze raz wielkie dzięki



ehh sry ze tak ciagle odswiezam ale znowu mam problem z tymi teksturami -.-
chodzi mi o to, ze chce aby moja mapka byla równomiernie oświetlona, kiedy wstawiam obiekty "light" to działa to na zasadzie ogniska. no więc pogrzebałem w worldspawn i wpisałem tam te dane :
suncolor 1.00 0.88 0.85
sundirection -20 315 0
sunlight 1.45"
sundiffusecolor 1.00 0.86 0.89
_color 1.00 0.781 0.275
diffusefraction. 45
ambient. 02
classname worldspawn



ale to nic nie pomogło ;/
macie jakieś pomysły? smiley
Wyślij Prywatną Wiadomość
Autor RE: problem
^Tomalla
Administrator

Dodane dnia 02-05-2011 18:26
Pisałem przecież, że na dłuższą skalę obiekty light nie są odpowiednie. Co do twoich opcji worldspawn to zacząłeś bardzo dobrze. Nie wiem tylko czy te literówki są spowodowane podczas przepisywania na forum, co jest prawdopodobne. Osobiście nie testowałem twojego zestawu opcji, ale czy próbowałeś gotowe zestawy, które są używane na oryginalnych mapach? Wtedy, jak mapa nadal będzie czarna, będziemy mieli pewność że problem nie leży bezpośrednio w parametrach worldspawn.

Zestawy możesz znaleźć tutaj:

http://modsonline.com/Tutorials-read-296.html

Wypróbuj parę i napisz czy działa.


=-.-=-.-=-.-=-.-=-.-=
Stary wyjadacz CoD2
Wyślij Prywatną Wiadomość
Autor RE: problem
~Smile
Użytkownik

Dodane dnia 02-05-2011 19:06
Witamy na forum, jeśli chodzi o światło na mapie najlepszym sposobem który u mnie wielokrotnie pomógł to:
1. Po zapisaniu mapy wejdź do
C:\Program Files\Activision\Call of Duty 2\map_source
(chyba, że masz zainstalowane gdzie indziej - ale wąpie bo radiant tego nie lubi)
2. Otwórz notatnikiem twój plik z mapą.
3. Całkiem u góry powinnien pojawić się podobny do tego wpis:
iwmap 4
// entity 0
{
----tutaj jakieś tam wpisy dotyczące ustawień worldspawnu----
// brush 0
{..... i tak dalej....




4. Dokładnie w miejsce ustawień wklej np:
"northyaw" "90"
"_color" "0.5 0.5 .62 1"
"ambient" ".1"
"sundiffusecolor" ".55 .75 .8"
"diffusefraction" ".5"
"classname" "worldspawn"
"sundirection" "-145 205 0"
"suncolor" ".55 .75 .8"
"sunlight" ".8"
"bouncefraction" ".4"




Zapisz i skompiluj.
Ustawienia które podałem są akurat dość ciemne ale i tak pewnie wszystko będzie wyraźne. Pamiętaj o "" który też musi tam być.

Jeśli chodzi o błędy które podajesz, są one wynikiem błędnie napisanego pliku:
C:\Program Files\Activision\Call of Duty 2/main/maps/mp/mp_prototype.gsc
4687197 www.codbrothers.co.uk Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 02-05-2011 19:29
@tomalla
próbowałem 2 mapek ale nie pomogło

@smile
no faktycznie miejscami wydaje sie jasniejsze ale i tak mi za ciemno smiley
ps. u mnie ten wpis w pliku z mapką po wklejeniu tych opcji od ciebie wygląda tak: (ps. nie było w tym miejscu wcześniej żadnych opcji worldspawn...)
iwmap 4
// entity 0
{
"northyaw" "90"
"_color" "0.5 0.5 .62 1"
"ambient" ".1"
"sundiffusecolor" ".55 .75 .8"
"diffusefraction" ".5"
"classname" "worldspawn"
"sundirection" "-145 205 0"
"suncolor" ".55 .75 .8"
"sunlight" ".8"
"bouncefraction" ".4"



"targetname" "elevator"
"classname" "worldspawn"
// brush 0
{



zobaczcie fotki mojej mapy, no średnio widać...
http://img691.imageshack.us/img691/4687/shot0000lo.jpg
http://img251.imageshack.us/img251/3957/shot0001la.jpg
http://img192.imageshack.us/img192/6285/shot0002bj.jpg
http://img9.imageshack.us/img9/9564/shot0003tzl.jpg
Wyślij Prywatną Wiadomość
Autor RE: problem
~Smile
Użytkownik

Dodane dnia 02-05-2011 19:49
wywal to:



"targetname" "elevator"
"classname" "worldspawn"




A reszte zamień na jaśniejsze kolory, tu masz dokładnie jak to powinno wyglądać:
iwmap 4
// entity 0
{
"sundiffusecolor" ".85 .9 1"
"diffusefraction" ".56"
"ambient" ".0"
"sundirection" "-40 -138 0"
"suncolor" "1 .95 .85"
"classname" "worldspawn"
"_color" ".85 .9 1"
"sunlight" "1.8"
// brush 0
{




to co masz wyżej po prostu wklej i skompiluj na nowo smiley
Edytowane przez Smile dnia 02-05-2011 19:50
4687197 www.codbrothers.co.uk Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 02-05-2011 19:55
jeszcze lepiej ale nadal za ciemno xD moze daj najjasniejsze parametry smiley
fotki:
http://img829.imageshack.us/img829/907/shot0005ai.jpg
http://img40.imageshack.us/img40/7909/shot0006at.jpg
http://img228.imageshack.us/img228/5985/shot0007k.jpg
Wyślij Prywatną Wiadomość
Autor RE: problem
~Smile
Użytkownik

Dodane dnia 02-05-2011 21:50
masz może gg/skype/xfire/steam będzie mi łatwiej pomóc
4687197 www.codbrothers.co.uk Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 02-05-2011 22:30
xfire : inspector24
Wyślij Prywatną Wiadomość
Autor RE: problem
@explo32wunderwaffe
Super Administrator

Dodane dnia 03-05-2011 21:18
Daj ambient 0.6 albo 1 to na pewno będzie jaśniej. A poza tym te ustawienia można inaczej wklepać. Wystarczy otworzyć w Radiancie mapę i wcisnąć "N", nie zaznaczając niczego wcześniej. I wtedy w polu "Key" np. "ambient", a w polu "Value" np. 1 i wcisnąć Enter. Potem z kolei wpisać key - "_color" i value - "0 0 0", znowu enter i zamknąć znowu klawiszem "N". Wtedy zapisać i skompilować.


3212459 explo32wunderwaffe lukaszu www.usmc-clan.tk Wyślij Prywatną Wiadomość
Autor RE: problem
~inspektor
Użytkownik

Dodane dnia 03-05-2011 23:32
explo32wunderwaffe napisał/a:
Daj ambient 0.6 albo 1 to na pewno będzie jaśniej. A poza tym te ustawienia można inaczej wklepać. Wystarczy otworzyć w Radiancie mapę i wcisnąć "N", nie zaznaczając niczego wcześniej. I wtedy w polu "Key" np. "ambient", a w polu "Value" np. 1 i wcisnąć Enter. Potem z kolei wpisać key - "_color" i value - "0 0 0", znowu enter i zamknąć znowu klawiszem "N". Wtedy zapisać i skompilować.


wielkie dzięki, o to chodziło! tzn o ten 'ambient' smiley
btw. dzieki wszystkim za zainteresowanie smiley
Wyślij Prywatną Wiadomość
Skocz do Forum: